Instalación de un módulo en Dolibarr

Home » Instalación módulo Dolibarr » Instalación de un módulo en Dolibarr
Instalación módulo Dolibarr No hay comentarios
image_pdfimage_print

En primer lugar hay que descargar el archivo del módulo (archivo .zip) desde la tienda online de 2byte.es (http://shop.2byte.es) o bien de la tienda oficial de dolibarr doliStore (http://www.dolistore.com).

• Debemos mover el archivo en el directorio raíz de Dolibarr.
• Descomprimir el archivo usando el comando: unzip modulefile.zip

En este momento el módulo ya está listo para ser activado desde la configuración de Dolibarr.

A PARTIR DE LA VERSIÓN DOLIBARR 3.2 ES RECOMENDABLE

Deberíamos repetir los pasos anteriores, pero debemos tener en cuenta: Desde la versión 3.2 es posible definir un directorio “root” alternativo, esto permite almacenar, en un mismo lugar módulos, plugins y temas. Tan sólo hay que crear un directorio en el Raiz de Dolibarr (por ejemplo “custom”), y seguidamente, hay que declararlo en el archivo conf.php.

Ejemplos de casos:

$dolibarr_main_url_root=’http://myserver’;
$dolibarr_main_document_root=’/path/of/dolibarr/htdocs’;
$dolibarr_main_url_root_alt=’http://localhost/custom’;
$dolibarr_main_document_root_alt=’/path/of/dolibarr/htdocs/custom’;

Copia el directorio del módulo, a el raiz del directorio “custom” (por ejemplo, llamado anteriormente)

VER VIDEO DE INSTALACIÓN:

 

ERROR: EL MÓDULO REQUIERE UNA VERSIÓN SUPERIOR DE PHP

Si obtienes este mensaje es porque la versión de PHP de tu servidor es un poco antigua, y si el resto de tus aplicaciones lo permiten, sería interesante que actualizaras la versión de PHP de tu servidor a una más reciente.

Si por el motivo que sea no puedes actualizar, puedes cambiar este parámetro en el módulo, aunque podría provocar algún fallo de funcionamiento. Debes ir al código fuente del módulo y en el fichero ../NombreMódulo/core/modules/modNombreModulo.class.php encontrarás una línea de este estilo:

$this->phpmin = array(5, 6);

Donde 5,6 correspondería a la versión 5.6 de PHP

y sustituirla por:

$this->phpmin = array(5, 4);

Donde 5,4 corresponde a la versión 5.4 de PHP

Según tus necesidades, sustituye la versión de PHP por la que necesites.

 

ERROR: ESTE MÓDULO REQUIERE UNA VERSIÓN DE DOLIBARR 4.0 O SUPERIOR

Si obtienes este mensaje es porque la versión de Dolibarr que estás usando es un poco antigua, y si el resto de tus módulos externos o programación a medida lo permiten, sería interesante que actualizaras la versión de Dolibarr a una más reciente.

Si por el motivo que sea no puedes actualizar, puedes cambiar este parámetro en el módulo, aunque podría provocar algún fallo de funcionamiento. Debes ir al código fuente del módulo y en el fichero ../NombreMódulo/core/modules/modNombreModulo.class.php encontrarás una línea de este estilo:

$this->need_dolibarr_version = array(4, 0);

Donde 4,0 correspondería a la versión 4.0 de Dolibarr

y sustituirla por:

$this->need_dolibarr_version = array(3, 7);

Donde 3,7 corresponde a la versión 3.7 de Dolibarr

Según tus necesidades, sustituye la versión de Dolibarr por la que necesites.